Alert: Legacy patches available for Windows Host ID changes, 4.4 break Maxline drivers

Hello everyone, couple things we wanted to share with you that will likely effect most of you at some point in the future:

Tridium releases legacy patches to match Host IDs to 4.3+, 3.8.213+

Tridium has released legacy patches to get older versions of Niagara to generate the same Host ID as 4.3+ and 3.8.213+. This is also the same Host ID that will not change when Microsoft releases major Windows 10 updates. The patches can be used to update any 3.6, 3.7, 3.8, or 4.2 installation. 4.0 and 4.1 are not supported, as well as any AX 3.5 installation or older.

For the full announcement and the patches, visit this Knowledgebase article (requires CTS login):

Niagara 4.4 incompatible with existing Maxline drivers

Niagara 4.4 does not work with any 4.3 or below Maxline drivers, and you will need an updated 4.4 version of the driver to get it working. For the latest download link to the 4.4 versions of your required driver, open a ticket with Cochrane Tech Support per usual and we will provide the latest link from Maxline.

Related Articles


Forgot password?
Register now